Press "Enter" to skip to content

Configuring EIGRP Step By Step

Configure EIGRP Step by Step

 

Before we dive into Configuring EIGRP Step by Step, why don’t we get ourselves aquainted with the technology of Understanding and Configuring EIGRP?

R1
interface s1/0
 ip address 172.16.24.2 255.255.255.0
 no shutdown
!
interface s1/1
 ip address 172.16.23.2 255.255.255.0
 no shutdown
!
router eigrp 100
 network 172.16.0.0
 
R2
interface Loopback0
 ip address 10.10.10.1 255.255.255.0
!
interface Loopback1
 ip address 10.10.11.1 255.255.255.0
!
interface s1/0
 ip address 172.16.24.1 255.255.255.0
 no shutdown
!
router eigrp 100
 network 10.0.0.0
 network 172.16.0.0
R3
interface Loopback0
 ip address 10.10.13.1 255.255.255.0
!
interface s1/0
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
router eigrp 100
 network 10.0.0.0
 network 172.16.0.0

 

Should I Enable Auto-Summarisation?
Under the premise of auto-summary, EIGRP automatically advertises classful summary routes to available EIGRP neighbors. Newer Cisco IOS release since version 15.0 now defaults to disabled. Aprior to this release, auto-summary was enabled by default. It is for this reason that the command “no auto-summary” is configured by engineers who understand the the setbacks auto-summarisation brings in deployments.

Let’s find out how exactly auto-summary actually works?

With auto-summary enabled by default in previous IOS releases, EIGRP performs checks for any directly connected interface subnets that falls within the range of your network command(s) and if this is the case, routes are automatically summarized to their respective classful masks and EIGRP advertises the classful A, B or C network to available neighbors.

It is important to note that auto-summary will only summarize routes from subnets attached to its interfaces, not the ones learned from other routers. This characteristic behaviour of auto-summarisation makes EIGRP incapable of supporting discontiguous networks when thus causing reachability issues.

As best practice, it is not recommended to manually enable auto-summarization but if based on design requirements you need to enable this then command auto-summary under the EIGRP routing process.

 
R1#
router eigrp 100
 auto-summary

R2#
router eigrp 100
 auto-summary

R3#
router eigrp 100
 auto-summary


You’ve configured EIGRP and can already see formed neighbourship but as shown in the diagram below R2 and R3 are advertising 10.0.0.0/8 (class A network) to R1 instead of advertising their /24, 10 dot network(s) as they traverse the major subnet boundaries. This snowballs a problem for R1 as it will assume it posesses two equal paths to reach 10.0.0.0/8, one through R2 and another through R3. This is rightly termed a discontiguous network situation. Beware that configuring must be an after thought to design. Always consider what could pose an issue for your network’s performance. So simply put, at all costs avoid auto-summarisation.

 
R1# show ip route eigrp | beg Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/409600] via 172.16.23.3, 00:00:09, s1/1
                 [90/409600] via 172.16.24.1, 00:00:09, s1/0

Come with me and let us verify reachability to loopback networks from R1. As you can see in the following output, some ping works and some doesn’t. This is because R1 has two equal cost summary route of 10.0.0.0/8 network – quite a confusing state for the Router in making forwarding decisions.

 
R1#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)

R1#ping 10.10.11.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/5 ms

R1#ping 10.10.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)

It’s worth noting that router R2 and R3 also install local EIGRP summary routes to Null0. The end result is that they cannot learn about each other’s summaries to 10.0.0.0/8, and reachability is not obtained between these networks as shown in the output below.

 
R3# show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D        10.0.0.0/8 is a summary, 00:01:06, Null0
      172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D        172.16.0.0/16 is a summary, 00:01:06, Null0
D        172.16.24.0/24 [90/307200] via 172.16.23.2, 00:01:03, s1/1

 
R3# ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

What is the best approach to solving this problem?

Two available options come to mind. Dispose off the discontiguous network from either router or disable the auto-summary configuration. Most ideally, you want to see the most specific networks in the routing table as you configure and advertise the networks using any dynamic routing protocol, not the classful summarised routes. Let’s go ahead and disable the auto-summary everywhere and see what results we get in the end.

 
R1#
router eigrp 100
 no auto-summary
 
R2#
router eigrp 100
 no auto-summary
 
 
R3#
router eigrp 100
 no auto-summary
 

Verify the route-table and reachability now. A very popular command used on Cisco IOS is show ip-route which we are going to use below to see exactly the changes obtained since we removed the auto-summary.

 
R1# show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 3 subnets
D        10.10.10.0 [90/409600] via 172.16.24.1, 00:00:50, s1/0
D        10.10.11.0 [90/409600] via 172.16.24.1, 00:00:50, s1/0
D        10.10.13.0 [90/409600] via 172.16.23.3, 00:00:43, s1/1
R1#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

R1#ping 10.10.11.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

R1#ping 10.10.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms

Manual Summarization

EIGRP is capable of supporting manual summarisation at the interface level using the ip summary-address eigrp command. This makes it possible to summarise at any interface participating in the EIGRP process. From a design perspective it is only intelligent to summarise routes to both reduce the size of the routing table and to limit the scope of EIGRP query messages. Using the Pasive Interface command can stop undue hellos from participating interfaces you do not need continued annoucements from. Summarising EIGRP routes keeps all subnets that make up the summary suppressed from being advertised out the link and only allowing the summarised network to be advertised.

Now let’s configure manual summarization on R2 so it summarise networks 10.10.10.0/24 and 10.10.11.0/24 to a single summary network.

R2(config)# interface s1/0
R2(config-if)# ip summary-address eigrp 100 10.10.10.0 255.255.254.0

Let’s check the route table of R1 again. R1 is now only receiving the summary network 10.10.10.0/23 from R2 as expected.

R1#show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D        10.10.10.0/23 [90/409600] via 172.16.24.1, 00:00:11, s1/0
D        10.10.13.0/24 [90/409600] via 172.16.23.3, 00:05:52, s1/1

Note When summaries are created in EIGRP, the router automatically installs a route to Null0 to match the summary. These summaries are used to prevent the router from forwarding traffic for destinations inside the summary that it does not have a longer match for. However, in certain designs, this can be an undesirable behaviour. To resolve this, EIGRP sets its interface-level summaries to have an administrative distance of 5 by default. Let’s verify the same on R2.

R2#show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D        10.10.10.0/23 is a summary, 00:12:56, Null0
D        10.10.13.0/24 [90/435200] via 172.16.24.2, 00:18:37, s1/0
      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D        172.16.23.0/24 [90/307200] via 172.16.24.2, 00:31:24, s1/0

R2#show ip route 10.10.10.0 255.255.254.0
Routing entry for 10.10.10.0/23
  Known via "eigrp 100", distance 5, metric 128256, type internal
  Redistributing via eigrp 100
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 128256, traffic share count is 1
      Total delay is 5000 microseconds, minimum bandwidth is 8000000 Kbit
      Reliability 255/255, minimum MTU 1514 bytes
      Loading 1/255, Hops 0

EIGRP summary route inherits metrics from its subnet with the best metric in use. Changing the best subnet metric means summary must be re-advertised all over again, you could at this point get a torn route which re-populates.

Let’s increase the bandwidth on Loopback0 interface of R2 and then verify the route metric of summary route.

R2(config-)# interface loopback0
R2(config-if)# bandwidth 1000000
R2#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(10.10.11.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.24.0/24, 1 successors, FD is 281600
        via Connected, s1/0
P 10.10.11.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.10.13.0/24, 1 successors, FD is 435200
        via 172.16.24.2 (435200/409600), s1/0
P 172.16.23.0/24, 1 successors, FD is 307200
        via 172.16.24.2 (307200/281600), s1/0
P 10.10.10.0/23, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 10.10.10.0/24, 1 successors, FD is 130560
        via Connected, Loopback0

Something worth knowing: upon summarising the external EIGRP route, the summary network becomes the internal EIGRP route.

Do You Already Know This?

Refer to the exhibit. Routers R1 and R2 have established a neighbor relationship and are exchanging routing information. The network design requires that R1 receive routing updates from R2, but not advertise any routes to R2. Which configuration command sequence will successfully accomplish this task?

 

A – R1(config)# router eigrp 1
R1(config-router)# passive-interface serial 0

B – R2(config)# router eigrp 1
R2(config-router)# passive-interface serial 0

C – R1(config)# access-list 20 deny any
R1(config)# router eigrp 1
R1(config-router)# distribute-list 20 out serial 0

D – R2(config)# access-list 20 deny any
R2(config)# router eigrp 1
R2(config-router)# distribute-list 20 out serial 0

E – R1(config)# access-list 20 permit any
R1(config)# router eigrp 1
R1(config-router)# distribute-list 20 in serial 0

F – R2(config)# access-list 20 permit any
R2(config)# router eigrp 1
R2(config-router)# distribute-list 20 in serial 0